Attack IQ | AIQ

Version

Version 0.1

Date

7th May 2025

Author 

Janice Lim

Confidentiality 

Public


Revision History 

Version 

Effective Date 

Prepared/ Amend By 

Summary of Changes 

Approved By 

1.0 

07/05/2025 

Janice 

  • 1st Draft

Jayden

1.1




 

 

 

 

 

 

 

 

 

 

1. Introduction 

This is a guide of uninstallation for Attack IQ Integration Manager Guide

2. Before You Begin 

 2.1. Preparation Pre-Requisite

  1. Access Level 

OVA deployment: sudo level access 

BYOL instance: any user with sudo privileges 

Obtain PEM Key 

For IM OVA, aiqadmin user’s PEM key needs to be retrieved from Integration Manager’s Maintenance console. 

  1. Login to your maintenance console on port 1443. 
    e.g. <IM address>:1443
     

A screenshot of a computer 
AI-generated content may be incorrect., Picture 

  1. Once logged in, change URL to <IM address>:1443/aiq-admin-user 

A screenshot of a computer 
AI-generated content may be incorrect., Picture 

  1. SSH key will be downloaded automatically. 
         A screenshot of a computer 
AI-generated content may be incorrect., Picture 


  1. Convert the key Using PuTTYGEN 

  1. 1. Click on Load and import the downloaded key. 

  2.      A screenshot of a computer 
AI-generated content may be incorrect., Picture 

  3.     A screenshot of a computer 
AI-generated content may be incorrect., Picture 
  1. 2. Click Save private key. 

  2. A screenshot of a computer 
AI-generated content may be incorrect., Picture 

 

 2.2. Safety and Precautions 


None 

3. Troubleshooting Process Overview 

  1. SSH to Integration Manager using PuTTY 

1. Go to Session and enter IM’s IP. 

A computer screen shot of a computer 
AI-generated content may be incorrect., Picture 

2. Go to SSH > Auth > Credentials Section and click Browse to import the private key saved previously. 

A screenshot of a computer 
AI-generated content may be incorrect., Picture 

3. Click Open. 

4. Login as aiqadmin 

A black and white screen with white text 
AI-generated content may be incorrect., Picture 

5. After login, run command: 

sudo bash -c 'cd /opt/attackiq/plugin/uninstall; ./uninstall.sh' 

A screenshot of a computer 
AI-generated content may be incorrect., Picture 

6. Then type: 1 


  1. AttackIQ Platform 

  1. 1. Login into AttackIQ Platform 

  1. 2. Go to TECHNOLOGY STACK > Integration Configuration 

  1. 3. The Integration Manager should display as Not deployed 

A screen shot of a computer 
AI-generated content may be incorrect., Picture
 
 

  1. 4. Select MORE OPTIONS > Remove Integration Manager 

 Picture 1, Picture
 

  1. 5. Click YES, UNINSTALL 

 A screenshot of a computer 
AI-generated content may be incorrect., Picture
 

  1. SSH to Integration Manager without Using PuTTY 

If not using putty, then once the key is downloaded, use the -i option to specify the file in your ssh command  

e.g. ssh -i <downloaded_privkey.pemaiqadmin@<ipaddr> 

4. Common Issues and Solutions 

4.1. Issue Identification Table 

Issue Description 

Possible Causes 

Initial Checks 

Suggested Solutions 





5. Step-by-Step Troubleshooting Guides 

None

6. Advanced Diagnostic Tools and Techniques 

Require Putty to SSH

7. Reporting Unresolved Issues 

None

8. Appendix and Additional Resources 

8.1. Glossary 

None

8.2. Tools and Resources List 

Putty

8.3. Contact Information 

Janice Lim